Update Your Browser

In 2016, upgrades were made to College computer systems to meet mandatory security requirements for online financial transactions.

Older browsers that do not meet these security standards will not be supported and this will impact your access to the RACP website.

To ensure an optimal online experience, please update your browser to the latest version.

Close overlay